Couple et Uncouple operations

General discussions

Moderator: senjer

Post Reply
User avatar
Citadis
Posts: 296
Joined: 11 Jul 2017, 12:14
Location: Grenoble, France
Contact:

Couple et Uncouple operations

Post by Citadis »

Hi there ! I just made this code for an testing activity, and I have some questions.

Code: Select all

<activity name="JoinSplit" mappack="LUI" mapfile="lui.map" time="08:00:00"> 
 <playerduty title="JoinSplit tests" starttime="08:00:00" endtime="08:20:00">
  <duty startpos="Southwick Park" starttime="08:00:00" endpos="Simpleton" endtime="08:05:00">
   <line1>Drive train 4012KS</line1>
   <line2>Make some tests</line2>
  </duty>
 </playerduty>
 
 <controldata system="0" pack="LUI" file="Routes316.ctd">
    <train code="401">
      <duty code="401" number="401#VS" route="Green-VS"  time="08:03:00" ai="true">
         <!-- <split blocks="4301,4302,4303" cab="2" newcode1="9994SS" newcode2="4013SA"/> -->
         <split blocks="4301,4302,4303" cab="1" newcode2="9993NN" newcode1="4013SA"/>
      </duty>
      <duty code="401" number="401#SA" route="Green-SA" time="08:09:00" ai="true"/>
    </train>
   <train code="402">
      <duty code="402" number="402#AS" route="Green-AS" time="08:03:00" ai="true">
         <!-- <join blocks="4301,4302,4303" junctiongroup="SPT" signals="SP12,SP34,SP14" train="999" reverseorder="true" newcode="4029SV"/> -->
         <join blocks="4301,4302,4303" junctiongroup="SPT" signals="SP12,SP34,SP14" train="999" newcode="4029SV"/>
      </duty>
      <duty code="402" number="402#SV" route="Green-SV" time="08:13:00" ai="true"/>
   </train>
   <train code="444">
      <duty code="444" number="444#KG" route="Green-KG" time="08:28:00" ai="true" />
      <duty code="444" number="444#GJ" route="Green-GJ-Fast" time="08:52:00" ai="true" />
   </train>

   <yard pack="LUI" file="SWD.cty" departures="auto" arrivals="auto">
      <shedule name="All" time="08:00:00" autodepartures="08:00:00" autoarrivals="08:00:00">
         <arrive code="402" train="4026SV" target="SWP" time="08:20:00" ai="true" track="4523" direction="-1" units="2" stop="1" />
         <depart code="444" train="4447KG" target="SWP" time="08:25:00" ai="true" track="4532" direction="1" units="1" signnumber="444" signdest="Green-GWR"/>
      </shedule>
   </yard>
 </controldata>
 
 <consists>
 <consist start="SWD11" controlsystem="0" trainnumber="4019VS" timetable="401" position="-9">
   <!-- <train pack="AlstomMetro" file="MF67_4car_Auteuil.xml">
    -->
    <train pack="AlstomMetro" file="MF67_3car_2012.xml">
      <cab id="0" ai="401" mycontrol="true"/>
      <car id="0" scrollsign1="1" scrollsign2="9" scrollsign3="99"/>
      <car id="1" scrollsign3="99"/>
      <car id="2" scrollsign1="1" scrollsign2="9" scrollsign3="99"/>
   </train>
   <train pack="AlstomMetro" file="MF67_3car_2012.xml">
	   <car id="0" scrollsign3="14" scrollsign2="01" scrollsign1="1"/>
	   <car id="1" scrollsign3="14"/>
	   <!-- <car id="2" scrollsign3="14"/> -->
	   <!-- <car id="3" scrollsign3="14"/> -->
	   <car id="2" scrollsign3="14" scrollsign2="01" scrollsign1="1"/>
   </train>
 </consist>

 <consist start="ADG6" controlsystem="0" trainnumber="4025AS" timetable="402">
   <train pack="AlstomMetro" file="MF67_3car_2012.xml">
	<cab id="0" enabled="true" ai="402"/>
	<car id="0" scrollsign3="14" scrollsign2="02" scrollsign1="12"/>
	<car id="1" scrollsign3="14"/>
	<!-- <car id="2" scrollsign3="14"/> -->
	<!-- <car id="3" scrollsign3="14"/> -->
	<car id="2" scrollsign3="14" scrollsign2="02" scrollsign1="12"/>
   </train>
 </consist>

 <consist start="SWD32">
   <train pack="London" file="LUS7.xml"/>
  </consist>
  
 </consists>
</activity>
1. With this code, the "split" train works successfully, but the joining train stays stuck at SP12 signal. Do you know why ?
Image
2. After uncouple, train 999 create a big gap between itself and the train previously coupled, and backwards in unusable aera. Is there any method to prevent that, or to reduce the gap ?
3. The train 402 (after manual control to pass the signal) doesn't want any more to couple with 999 still at station. How can I correct it ?
4. After depot departure, train 444 is not recognized as it should be. Well I don't know where this can came from

Last, I identified in a file, a <joinsplit /> tag. How to use it ?

Tkanks for answer
Citadis
Citadis : French Type of trams (yes, i'm french :) )
Sorry for my english but enjoy Metro Sim Beta !
Image
Post Reply