Page 1 of 26

London Underground trains

Posted: 23 Dec 2018, 14:32
by Sjoerd
As promised ("before the end of this month"), the London Underground rolling stock package.
Originally, I planned this for 3.15, but as a releasedate is not known yet.... Well, they work in 3.14 too :D

This package contains several series of rolling stock for Metrosimulator;

Tube trains:

* 1973 stock, single ended unit
* 1973 stock, double ended unit
* 1995 stock, single ended unit

Subsurface trains:

* D78 stock, single ended unit (original livery)
* D78 stock, double ended unit (original livery)
* D78 stock, single ended unit (modern livery)
* D78 stock, double ended unit (modern livery)
* S7 stock
* S8 stock

Image

There are a few activities included which use these trains in the different Rijndam maps. Not the S8 however, as the stopmarkers at the platforms in the current released Rijndam maps haven't been set correctly for the S8. I have fixed this in Rijndam, but that has to wait for the next release. In the mean time (in 3.14); the S8 is usable, but the AI won't stop at most stations (even though a lot of the platfoms are in fact long enough).

In order to use these vehicles in your own activities, you can use these codelines:

<train pack="London" file="LU1973_SE.xml"/> 1973 stock, single ended unit. Must couple 2 back-to-back to form a complete train.
<train pack="London" file="LU1973_DE.xml"/> 1973 stock, double ended unit.

<train pack="London" file="LU1995_A.xml"/> 1995 stock, single ended unit, front half of a complete train.
<train pack="London" file="LU1995_B.xml"/> 1995 stock, single ended unit, rear half of a complete train.

<train pack="London" file="LUD78_A.xml"/> D78 stock, single ended unit, front half of a complete train.
<train pack="London" file="LUD78_B.xml"/> D78 stock, single ended unit, rear half of a complete train.
<train pack="London" file="LUD78_DE.xml"/> D78 stock, double ended unit.

<train pack="London" file="LUD78_old_A.xml"/> D78 stock old livery, single ended unit, front half of a complete train.
<train pack="London" file="LUD78_old_B.xml"/> D78 stock old livery, single ended unit, rear half of a complete train.
<train pack="London" file="LUD78_old_DE.xml"/> D78 stock old livery, double ended unit.

<train pack="London" file="LUS7.xml"/> S7 stock, complete train.
<train pack="London" file="LUS8.xml"/> S8 stock, complete train.


The 'half' trains are all equipped with shunting controls at the rear end, cabview 2 position, which can be opened with Shift+X (when in that position).
Window wipers always function on Ctrl+Shift+X



>> Download: https://filehorst.de/d/czCerJea <<



The 1973 stock train will be visible twice in the simulator, as it is also already present in the beta314.000-file.

Note: The 3rd and 4th rail pickups do not align anymore with the 3rd/4th rails on line M7. This is due to the pickups having been updated to the correct positions found online (Thanks to Michiel :D ). In new releases, I will also update the 3rd/4th rails. ;)

Re: London Underground trains

Posted: 23 Dec 2018, 15:26
by <Swaggerboy>
:mrgreen: Im downloading it now and super excited to test them!! :mrgreen:

Re: London Underground trains

Posted: 24 Dec 2018, 09:08
by brozma
Wow, what a nice present for christmas! Can't wait to test them! ;)

Re: London Underground trains

Posted: 24 Dec 2018, 11:55
by Alfacinha315
@Sjoerd thanks for the London Underground stock, I was testing it and they're all great. :)

However, in the D78 stock activity for Rijndam 1985 there's a train remaining at the Station Westplein sidings with two cabs turned on (near the platforms and near the buffer), not allowing it to depart and, consequently, causing a traffic jam. I noticed that when I was leaving Bergenseweg and got stuck between the two stations. I had to get into that train and turning off the cab near the buffer, in order to depart and leaving space for the next M1 trains.

Can you please fix that error until the next release (beta 3.15)?

Thank you and merry Christmas! ;)

Re: London Underground trains

Posted: 24 Dec 2018, 13:17
by Sjoerd
Sadly, that error can't be fixed. It is due to the simulator calculating the positions of the trains at certain intervals (multiple times per second). Sometimes, a train misses the point where it should shut off, and therefore remains "on". The only way to fix that, is by increasing the number of simulationsteps per second, which I can not do.
@Michiel; correct me if I am wrong....

Re: London Underground trains

Posted: 24 Dec 2018, 21:39
by rik079
Do this trains really have to be released in my videogame-free week? :lol: :lol: :(

Re: London Underground trains

Posted: 27 Dec 2018, 16:09
by <Swaggerboy>
Too bad that the Glasgow SPT hasn’t been released yet. :|

Re: London Underground trains

Posted: 27 Dec 2018, 16:12
by Sjoerd
<Swaggerboy> wrote:
27 Dec 2018, 16:09
Too bad that the Glasgow SPT hasn’t been released yet. :|
It is ready. It will go online as soon as 3.15 is released, as it can conflict (file references for example) with the older Glasgow version that has been build into 3.14. ;)
When does 3.15 go online? I do not know.

Re: London Underground trains

Posted: 28 Dec 2018, 12:14
by Piccadilly
Sjoerd wrote:
27 Dec 2018, 16:12
<Swaggerboy> wrote:
27 Dec 2018, 16:09
Too bad that the Glasgow SPT hasn’t been released yet. :|
It is ready. It will go online as soon as 3.15 is released, as it can conflict (file references for example) with the older Glasgow version that has been build into 3.14. ;)
When does 3.15 go online? I do not know.
Can you do a preview video of it on Glasgow? On your YouTube?
Thanks

Re: London Underground trains

Posted: 31 Dec 2018, 16:22
by jameswldn
Please can someone give me step by step instructions on how to add the LU trains onto the game. I tried following the read me but it is not working.
Thx and happy new year